Invoice Import Issue
Incident Report for Restaurant365
Resolved
This incident has been resolved.
Posted Sep 17, 2019 - 11:27 PDT
Investigating
We are currently investigating the issue and will provide updates when available.
Posted Sep 17, 2019 - 09:51 PDT
This incident affected: Connected Integrations (FTP File Watcher (Vendor Integration)).