System Slowness

Incident Report for Restaurant365

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 10:45 PDT

Monitoring

We've identified the root cause of slowness, and a fix has been pushed. We're seeing recovery and will monitor until resolved.
Posted Jul 01, 2026 - 09:31 PDT

Investigating

We're investigating system-wide slowness for certain customers.
Posted Jul 01, 2026 - 09:23 PDT
This incident affected: Website (Customer Databases).