System Issues
Incident Report for Restaurant365
Resolved
Our engineering team has resolved the issue.
Posted Feb 28, 2023 - 10:38 PST
Investigating
We are experiencing intermittent system issues that are impacting some customers' ability to access R365. Our engineering team is addressing this matter as a top priority. We will post updates here as they become available.
Posted Feb 28, 2023 - 10:02 PST
This incident affected: Website (Customer Databases).