Radar Login Slowness

Incident Report for Restaurant365

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 11:24 PDT

Monitoring

A fix has been pushed, and we're seeing recovery. We'll continue to monitor for slow performance.
Posted Jun 25, 2026 - 11:09 PDT

Investigating

We are investigating reports of slowness for certain customers while logging into Radar.
Posted Jun 25, 2026 - 10:45 PDT
This incident affected: Radar (Radar Services).