Multi-Factor Authentication

Incident Report for Restaurant365

Resolved

This incident has been resolved, and MFA challenges are being sent as expected.
Posted May 28, 2026 - 06:55 PDT

Monitoring

A fix has been implemented and MFA challenges are being sent. We'll continue to monitor.
Posted May 28, 2026 - 06:37 PDT

Investigating

We are investigating reports that MFA is not working as expected for certain users.
Posted May 28, 2026 - 06:32 PDT
This incident affected: Website (Customer Databases).