Reports of Slowness

Incident Report for Restaurant365

Resolved

With reports indicating full recovery, we are marking this incident as resolved.
Posted May 18, 2026 - 14:34 PDT

Monitoring

A fix was implemented, and we are seeing signs of recovery. We will continue to monitor the results.
Posted May 18, 2026 - 11:18 PDT

Investigating

We are investigating multiple reports of slowness. We will provide updates as our research continues.
Posted May 18, 2026 - 09:18 PDT
This incident affected: Website (Customer Databases) and Reporting (My Reports).