Reports of Slowness

Incident Report for Restaurant365

Monitoring

A fix has been implemented, and we are continuing to see signs of recovery across affected services. We will continue to monitor system performance closely and provide updates as needed.
Posted Jun 01, 2026 - 11:08 PDT

Investigating

We are currently investigating reports of slowness
Posted Jun 01, 2026 - 08:48 PDT
This incident affects: Website (Customer Databases) and Reporting (Ad Hoc, My Reports, Custom Financials Reporter, R365 Intelligence).