Reports of slowness for payments to be calculated

Incident Report for Restaurant365

Resolved

We are continuing to see recovery and now consider this incident resolved.
Posted Apr 07, 2026 - 17:04 PDT

Update

We are continuing to monitor the fix implemented to ensure full recovery
Posted Apr 07, 2026 - 14:44 PDT

Monitoring

A fix has been implemented and we are now monitoring the results
Posted Apr 07, 2026 - 12:28 PDT

Identified

The root cause has been identified, and a fix is currently being implemented.
Posted Apr 07, 2026 - 10:57 PDT
This incident affected: Website (R365 Payroll).