R365 Payroll Processing Unavailable

Incident Report for Restaurant365

Resolved

This incident has been resolved, and Payroll Processing has resumed.
Posted Jun 15, 2026 - 16:16 PDT

Investigating

We’re currently experiencing an issue affecting Payroll Processing, which is temporarily unavailable. Our team is actively working to restore functionality as quickly as possible. We appreciate your patience and will share updates as soon as we have more information.
Posted Jun 15, 2026 - 15:25 PDT
This incident affected: Website (R365 Payroll).